www.broadpeak.io website is down

Incident Report for broadpeak.io

Resolved

The website www.broadpeak.io is up again. The issue was due to an expired certificate.
Posted Nov 14, 2025 - 13:31 UTC

Identified

We have identified the issue and a fix is in progress
Posted Nov 14, 2025 - 13:23 UTC

Investigating

There is no impact on streaming or service configuration webapp (https://app.broadpeak.io is up and running)
Posted Nov 14, 2025 - 10:30 UTC
This incident affected: Broadpeak.io Website.