Ongoing AWS Outage in US Region

Incident Report for broadpeak.io

Resolved

AWS outage is resolved.
Posted Oct 21, 2025 - 07:09 UTC

Investigating

Due to an ongoing AWS outage impacting the US region, the platform cannot currently provision additional compute resources in this area.

Existing services remain fully operational, but scaling capacity is temporarily limited. This may affect performance if streaming demand increases significantly.

We are closely monitoring the situation with AWS and will provide updates as soon as normal operations resume.

Other regions are not impacted
Posted Oct 20, 2025 - 14:14 UTC
This incident affected: Broadpeak.io Applications (Content Replacement application, Virtual Channel application, Dynamic Ad Insertion application).